nixconf/nfs-mount.nix
2025-04-11 07:44:12 +02:00

20 lines
400 B
Nix

{ config, pkgs, ... }: {
systemd.mounts = [{
type = "nfs";
mountConfig = {
Options = "noatime";
};
what = "${config.vars.nfs_server}:${config.vars.nfs_volume}";
where = config.vars.nfs_mount;
}];
systemd.automounts = [{
wantedBy = [ "multi-user.target" ];
automountConfig = {
TimeoutIdleSec = "600";
};
where = config.vars.nfs_mount;
}];
}